Select Page

Appcelerator Titanium Studio or eclipse sometimes removes my projects from the Build->Clean options. When this happens, the build option is normally also missing. I have not figured out yet why this weird problem exist but here is the fix for when you stumble upon this issue.

This happens at random intervals. The problem is that the .project file is missing the required build commands. What you need to do is copy the following into your .project file.

This is a hidden file and you can view it either by using GIT source control from inside Appcelerator, go to the working folder and look for the .project file, open it from inside Titanium Studio or enable hidden files on your mac by following this tutorial. Show hidden files in Mac OSx

Add the following to the .project file:

<buildSpec>
	<buildCommand>
		<name>com.appcelerator.titanium.core.builder</name>
		<arguments>
		</arguments>
	</buildCommand>
	<buildCommand>
		<name>com.aptana.ide.core.unifiedBuilder</name>
		<arguments>
		</arguments>
	</buildCommand>
</buildSpec>

Once completed all should be in order.

Remember:
A project only shows up in the Clean dialog, if it has some kind of builder registered. You can check this by opening the project properties, and look for the Builders tab. If there are no builders, then it should not be visible.
If that is the problem, then you should try to identify at what point does your .project file in the project folder changed; that might give a hint about the culprit.